Can't post classified ad

Not sure why this is happening, but I can post a classified ad. I fill out all the fields, hit submit, and then it says “invalid post”. No mention of why. Any ideas?

Did you choose a category?

Thanks, I got it to work. I tried to post a link to the manufacturer’s website in the description, but for some reason, it didn’t like that. After removing that, it was fine.

1 Like

they may have that set up to block having dealers place commercial ads in the classified section

1 Like

I’ve been trying to post a classified for several days – seems impossible! I do all the steps, but when I click on the Publish button, nothing ever gets published! I try a half dozen times, wait a few hours, and then I try another few times, over and over! And I don’t post a link, as you did initially. In the past, this has been the best place for selling a high-quality used kayak, but it seems to be broken? I’m glad that you finally got the website to work.

Thanks, and good luck. Maybe make sure all you have in there is text. If you don’t have any links, I’m not sure what the issue could be. Maybe picture size is too big? The classified posting process seems to be really flaky. I hope they can get it sorted out.

Thanks for your concern. The problem was the box that asked for the price. I typed in $2900., $2,900, $2,900.00, $2900. Each was rejected. Finally, I tried 2900, and that worked! The box wouldn’t accept a $ or comma or period.