I'm trying to post a kayak for sale - I push publish and nothing happens

Anyone else had this problem?

I recently listed my Fathom LV for sale and had no issues.

Does the forum have a “you must be a member for x number of posts” before you can sell rule?

Here’s the classified FAQ. Says nothing about membership term.

I can try and look up your posting, to see if it just got hid somehow. Can you tell me the title you used?


Walrus Griffin Carbon Fiber Kayak for Sale

I tried posting my Griffin again today and got the same result - nothing happened when I hit the PUBLISH button. I never had any trouble with this website when I had to pay to advertise. What’s going on?

Haven’t been able to recreate any issues yet. Can I ask your device and browser, and if you have any plugins installed on the browser? Like Adblock, or Tracking Blockers


I’m using iMac desktop and Safari - no plugins that I know of.

I have continuous problems with this site when submitting or answering PM’s if or “when” i can bring them up. Also tried for 2 months to access my add to edit it, with no luck. Yes I’m a member. - Snarvol

Try using a different browser, as that’s most likely the issue.

I constantly run into websites that won’t work with Firefox and the extensions I have installed, so I keep a “clean” version of Chrome available that always seems to work with those sites. I also use an extension called “Open With” that puts an icon in your browser’s tool bar that allows you to open the website you’re on in another browser quickly.

Thanks. I did try using the Chrome browser and was able to post the Ad.

1 Like

Thanks. Your comment led me to try Chrome rather than Safari. It worked!

1 Like

Glad to hear it. We might need to look into Safari to see if we can figure out why it isn’t playing as nice with the site as it should.


Thanks. Good luck with that. It was pretty frustrating.