Is there a way for the author of a 'Kayak Review' to edit it?

I wrote a review of the Petrel Play a couple days ago.
I did it in Notepad, then just pasted it into the ‘Review’ page.

I see that is up there now (, but does not have any formatting - it’s all one paragraph (no CR/LF).

Is there a way for the writer of a review to edit it?

Maybe @brian can answer your question.

If you posted very recently, you will see a graphic of a pencil on the line below your post along with “reply” and other options. That allows you to edit. This does not stay active forever. I don’t know how long it is active for. If you delete everything, I believe that your name with a notice that the post has been deleted and that notice will disappear after 24 hours. I assume that you have the option to change your mind and repost before the 24 hours is up.

After the edit icon disappears, I don’t think that there is any way for a used to make further changes.

Thanks Rookie, I’ll try the ‘Message’ option when clicking on @brian

Thanks rstevens15, if the ‘Submit Review’ also has this option (like the forum messages), the time expired before I had a chance to use it.

@raisins there is a formatting bug that we are working to address. We can see all the formatting on the back end of the site but it isn’t displaying properly on the front end of the site.
We are investigating and hope to have a fix out soon.


Thanks much.
If you would like me to resubmit the review, just let me know.

Those reviews so are screwed up its not funny. My review from a few years ago doesn’t show. Heck if you do a search for Tiderace you get zero results. So my tiderace review isn’t there and no one else ever reviewed any tiderace boat. Hard to believe.

what model,
is it one of these:

maybe the ‘submitted by’ name got messed up when the website was moved a couple years ago,
eg is ‘paddler428564’ a real paddler user.

That’s wild. I cant even get to that page myself. If I go to main page , then click on Gear&Reviews then touring. then use keyword search and type Tiderace you get ZERO results. The direct link you gave above works BUT I cant get to that page.

The search is buggy for me. I went to the Gears and Reviews: Kayaks page. I typed in Tiderace in the text box next to the magnifying glass icon and hit carriage return. Nothing happened. Then I scrolled down, scrolled back up, and magically a drop down appeared below the text box with a list of selections including individual models. Tried it again, no drop down, nothing. Minimized the window, reopened, boom there’s the drop down.

Everyone - this is how the search within the gear section should work (or look):

It should auto-complete as you type.

As for individual reviews, if a review was tied to a user account on, it should still be assigned to that user account on If you find a review that should be assigned to you, please contact and we can make the update.

NOW its working. LOL. This site is as buggy as it was when they did that redo of the forum making this sight much worse. Nothing got better. just the opposite…

@Kevburg If you are able to capture a screen recording of what you see when it doesn’t work, that would be really helpful. You can send it to me via PM.
A simpler option is to go to and then send me the link that displays in the right column.

@dc9mm feel free to PM me with any issues you see. We are constantly fixing bugs but need to be aware of the issues.

This morning it is working as you describe - I see the type ahead and don’t have to do something to force a re-layout of the screen in order to see the drop down. If the code hasn’t changed since yesterday then my best guess would be slow internet upload times at my end?

Glad it’s working now. Nothing has changed in the code but we did deploy a bunch of other, unrelated updates to yesterday and that may have caused some temporary slow downs then.

It is also working for me too now. I am doing the exact same thing as I did before. BUT now it works. Go figure.

1 Like