Point 65 SeaCruiser rudder mount not locking

Hi, I just acquired a used Point 65 SeaCruiser kayak. It needs a few repairs, one of which seems to be a problem with the rudder. My understanding is that it uses what is called a bayonet-style pin. I’ve tried turning it to lock it down (as shown in one of their manuals), but nothing catches. I see the notch on the rudder’s pin, but when I look down the sleeve in the hull I see nothing for it to lock on to (I even tried running a small screwdriver down the sides to feel for anything). Is the sleeve broken? I see that Point 65 sells a rudder sleeve on their site, but how does one remove the old one?
Thanks for any help and advice!

So I’ll comment on my own post so that someone else searching for an answer might find this helpful. I bought the replacement sleeve and indeed it does have a little post that catches the rudder pin and locks it down. I guess my original one was broken by the previous owner (probably forced it, not aware of the correct way to remove it by turning it to the appropriate angle).
I still haven’t figured out how to remove the old sleeve, but I’m thinking I’ll try turning a lag bolt into it so that I have something to pull out. I might wait until the end of the paddling season to do this as it basically works fine held by gravity (of course it could fall out if I roll …).